Back to overview
Degraded
Server maintenance
Oct 15 at 02:56pm CEST
Resolved
Oct 15 at 03:33pm CEST
All services are operational again.
Affected services
Updated
Oct 15 at 03:09pm CEST
Server updates are done. One upgrade is still in progress but should only effect the Outlook API.
Affected services
Created
Oct 15 at 02:56pm CEST
We are updating our Production servers, downtime should be minimal.
Affected services